FAQ  •  Register  •  Login

018 still the same bug

Forum rules
This forum is for technical discussion only. If you are interested in gameplay or client-side issues, please post in Bitfighter Features.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Wed Sep 12, 2012 4:09 pm

018 still the same bug

I just got the latest version of Bitfighter 18, compiled and when I hit space bar, boost, and when I hit right click, nothing. I changed the controls and tried it: it works. Then when I wanted to put back right click as second module, nothing. I can't use right click in bitfighter at all. It works out of Bitfighter, in Finder, other apps etc. Help!

I have a PowerBook G4 15" 1.67 GHz, 1 GB DDR2 SDRAM, Mac os 10.5.8.

Help!
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Wed Sep 12, 2012 4:11 pm

Re: 018 still the same bug

Just tried 17b and right click works in 17b.
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Wed Sep 12, 2012 4:41 pm

Re: 018 still the same bug

Are you still using a non-standard mouse (i.e. the trackpad)?

What happens if you use a normal USB mouse?
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Wed Sep 12, 2012 5:22 pm

Re: 018 still the same bug

I just tried a normal common usb mouse and exactly the same problem.
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Wed Sep 12, 2012 10:28 pm

Re: 018 still the same bug

What Mac system are you using? 10.6/10.7/10.8?

Thanks!
<<

sam686

User avatar

Posts: 468

Joined: Fri Oct 15, 2010 8:53 pm

Location: United States, South Dakota

Post Thu Sep 13, 2012 5:26 pm

Re: 018 still the same bug

raptor wrote:What Mac system are you using? 10.6/10.7/10.8?
First post says this:
Fordcars wrote:I have a PowerBook G4 15" 1.67 GHz, 1 GB DDR2 SDRAM,
Mac os 10.5.8.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Thu Sep 13, 2012 5:29 pm

Re: 018 still the same bug

I am ashamed
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Fri Sep 14, 2012 4:04 pm

Re: 018 still the same bug

@Fordcars

I just pushed a fix to mercurial. Check out the latest and recompile.

The bug was a regression introduced in SDL2 that I reverted. I recompiled the framework for bitfighter with the patch.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Tue Sep 18, 2012 8:22 pm

Re: 018 still the same bug

Thanks! I will try it out soon.
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Sun Sep 23, 2012 1:04 pm

Re: 018 still the same bug

Ok I just hg pulled -u it and still the same bug. No right-click in the hole game!
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Sun Sep 23, 2012 1:05 pm

Re: 018 still the same bug

Are you sure you haven't deleted the input for right-click? What method are you using (I'm too lazy to find the inputs in the long code.)
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Sun Sep 23, 2012 2:47 pm

Re: 018 still the same bug

Did you recompile from scratch? I added a new SDL2.framework that should have fixed the problem.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Sun Sep 23, 2012 5:55 pm

Re: 018 still the same bug

Well I was to lazy to wait like 5 minutes to compile so I took the debug.

Was that wrong?
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Sun Sep 23, 2012 6:10 pm

Re: 018 still the same bug

Ok NOW I compiled it and... (drum roll)... tsh! Still the same problem!
Ahhhhhhhhhh...
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Mon Sep 24, 2012 4:37 pm

Re: 018 still the same bug

I have verified it works on several Mac systems, and Little_Apple has also verified it works.

Maybe you need to update mercurial to the latest revision?:
  Code:
hg pull -u
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Mon Sep 24, 2012 6:00 pm

Re: 018 still the same bug

Well I just hg pulled it and tried debug, still the same. I guess It's just computer or ppc architecture :(
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Mon Sep 24, 2012 6:07 pm

Re: 018 still the same bug

I guess it's a big deal. This computer is the "programming" computer. I have another computer for gaming.
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.

Return to Technical Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron