FAQ  •  Register  •  Login

What the h3ll is wrong with my server!?!

Forum rules
This forum is for technical discussion only. If you are interested in gameplay or client-side issues, please post in Bitfighter Features.
<<

Bit Preadtor

Posts: 8

Joined: Mon Feb 25, 2013 5:57 pm

Location: Somewhere in the Gamescape

Post Mon Mar 18, 2013 5:41 pm

What the h3ll is wrong with my server!?!

Ever since the last update this is what i see from the in the server logs


Bit Praedtor [Local Connection] joined [2013-03-17 Sun 21:34:36]
Loading Infection [Infected.level]... Done. [2013-03-17 Sun 21:34:48]
***ROBOT ERROR*** Method _stackTracer() could not be found!
Your scripting environment appears corrupted. Consider reinstalling Bitfighter.

Bit Praedtor [IP:Any:0] quit [2013-03-17 Sun 21:35:41] (65.00 secs)
----------
Bitfighter server started [2013-03-17 Sun 21:38:02]
hostname=[Space Campain], hostdescr=[New Race coming out But under construction]
Loaded 17 levels:
Ambush.level [Ambush.level]
Bitmatch01 [bm.level]
Contact [Contact.level]
Core03 [core.level]
Capture01 [ctf.level]
Deadspace [Deadspace.level]
Hold01 [htf.level]
Seige [Incoming.level]
Infection [Infected.level]
Map.level [Map.level]
MazeRacer [mazeracer.level]
Nexus01 [nexus.level]
Rabbit01 [rabbit.level]
Retrieve01 [retrieve.level]
Hectogram/Polytherom confict 1 [Skirmish1.level]
Soccer01 [soccer.level]
Zone01 [zc.level]
Loading Ambush.level [Ambush.level]... Done. [2013-03-17 Sun 21:38:02]
Bit Praedtor [Local Connection] joined [2013-03-17 Sun 21:38:02]
Bit Praedtor [IP:Any:0] quit [2013-03-17 Sun 21:38:44] (42.00 secs)

i have no idea what is wrong i even asked Raptor and he has no clue can anyone provide any answers :?:
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Mon Mar 18, 2013 5:53 pm

Re: What the h3ll is wrong with my server!?!

Well, if raptor doesn't know, nobody knows.
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Mon Mar 18, 2013 6:03 pm

Re: What the h3ll is wrong with my server!?!

Hi,

I do have a clue... sometimes.

I think it's because it isn't detecting the 'scripts' directory.

Can you please load diagnostics in-game (press F7) and look at the 'folders' screen (press F7 once or twice more). Take a screen shot of your directories (CTRL + Q - saves to %appdata%/Bitfighter/screenshots) and post it here.

Thanks!
<<

Bit Preadtor

Posts: 8

Joined: Mon Feb 25, 2013 5:57 pm

Location: Somewhere in the Gamescape

Post Mon Mar 18, 2013 6:31 pm

Re: What the h3ll is wrong with my server!?!

screenshot_1.png

heres the Image
You do not have the required permissions to view the files attached to this post.
<<

raptor

Posts: 1043

Joined: Mon Oct 11, 2010 9:03 pm

Post Mon Mar 18, 2013 6:55 pm

Re: What the h3ll is wrong with my server!?!

excellent!

See that one called 'Lua Dir'?

Make sure that folder exists and has files in it. Also, the specific file it is looking for is called 'stack_trace_plus.lua'. Make sure that file exists. If it doesn't you can get it from here:

https://bitfighter.googlecode.com/hg/re ... e_plus.lua

Depending on what you find out, I'll ask more questions to determine if it was an installation issue or other issue.

Thanks!
<<

Bit Preadtor

Posts: 8

Joined: Mon Feb 25, 2013 5:57 pm

Location: Somewhere in the Gamescape

Post Tue Mar 19, 2013 5:18 am

Re: What the h3ll is wrong with my server!?!

Yes it is there

the following in my scripts:
build_navzones.lua
geometry.lua
getopt.lua
inspect.lua
levelgen_helper_functions.lua
list.lua
lua_helper_functions.lua
plugin_arc.lua
robot_helper_functions.lua
and the one your looking for: stack_trace_plus.lua
and finaly timer.lua
<<

watusimoto

Site Admin

Posts: 1558

Joined: Tue Feb 23, 2010 7:07 pm

Location: Quartz's mom's house

Post Tue Mar 19, 2013 3:03 pm

Re: What the h3ll is wrong with my server!?!

I'm not sure what's going on -- raptor's right in suggesting that the required file was missing, even though in your case it isn't. Something else must be going on.

Could you try installing Bitfighter in portable mode? Perhaps the easiest way is to copy the installation folder elsewhere, then add a file called 'standalone.txt' (contents unimportant) to the folder. Then you can run your copy of the game from this new folder.

Report back what happens.
<<

Lamp

User avatar

Posts: 426

Joined: Fri Jan 11, 2013 3:07 pm

Post Tue Mar 19, 2013 5:15 pm

Re: What the h3ll is wrong with my server!?!

Maybe the file is corrupt? Try reinstalling it from the link raptor gave you.
Image
<<

sam686

User avatar

Posts: 468

Joined: Fri Oct 15, 2010 8:53 pm

Location: United States, South Dakota

Post Tue May 07, 2013 3:02 pm

Re: What the h3ll is wrong with my server!?!

You probably have outdated version of those scripts...

Go to folder C:\Users\user\AppData\Roaming
Rename "Bitfighter" to something like "Bitfighter_old"
Then run bitfighter.

Quit Bitfighter and "Bitfighter" folder appears with updated files. You can copy over Bitfighter.ini (settings), and your levels from bitfighter_old to your new "Bitfighter" folder. Don't copy or edit the scripts files.

Now try again. Does "/addbot s_bot" work now when you are hosting?


I found that in 018a, new versions of scripts and robots fails to get updated to user's files (even with the removal of only bitfighter.ini), until the entire "Bitfighter" folder is not there in user's files.

As a side note, I don't think anyone will ever edit files in the scripts folder, so it may be better to not have "scripts" appear in user's files due to possible version mismatch scripts.
<<

Fordcars

User avatar

Posts: 1014

Joined: Fri Apr 20, 2012 3:51 pm

Location: Some city, somewhere

Post Wed May 08, 2013 8:34 am

Re: What the h3ll is wrong with my server!?!

Well I normally use it for levelgens and sometimes other stuff
skybax: Why is this health pack following me?
bobdaduck: uh, it likes you.

Return to Technical Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron