FAQ  •  Register  •  Login

Linking Error: ALut.lib

Forum rules
This forum is for technical discussion only. If you are interested in gameplay or client-side issues, please post in Bitfighter Features.
<<

Unknown

User avatar

Posts: 183

Joined: Mon Mar 08, 2010 4:48 pm

Post Thu May 26, 2011 2:52 pm

Linking Error: ALut.lib

1>------ Build started: Project: bitfighter, Configuration: Debug Win32 ------
1>LINK : fatal error LNK1104: cannot open file '../lib/ALut.lib'
========== Build: 0 succeeded, 1 failed, 3 up-to-date, 0 skipped ==========

I have all of the win_include_do_not_distribute stuff, but I have no clue where ALut.lib would be from. I looked it up online and I can't find it. What is going on?
<<

raptor

Posts: 1022

Joined: Mon Oct 11, 2010 9:03 pm

Post Thu May 26, 2011 9:33 pm

Re: Linking Error: ALut.lib

Hi,

At what changeset are you compiling?

You should know that anything after 015a may be severly borken...
<<

ZoombeR

Posts: 1036

Joined: Fri Jun 04, 2010 11:56 pm

Post Thu May 26, 2011 10:51 pm

Re: Linking Error: ALut.lib

he made a post at
Thu May 26, 2011 1:47 pm
saying he was going to look at the code and see if he can modify something himself. So if he cloned a copy when he made the post he could probably be changeset 3f2e107ca36f
unless is using an old copy and just decided to modify that
<<

raptor

Posts: 1022

Joined: Mon Oct 11, 2010 9:03 pm

Post Fri May 27, 2011 6:59 am

Re: Linking Error: ALut.lib

I sure hope he didn't use that revision... anything after tag 'bitfighter-015a' we cannot really support since we are in heavy, heavy development (read broken code.)

If it was cloned at the latest, i suggest changing to changeset 'bitfighter -015a' and working from that:
  Code:
hg up bitfighter-015a
<<

Unknown

User avatar

Posts: 183

Joined: Mon Mar 08, 2010 4:48 pm

Post Sat May 28, 2011 3:23 pm

Re: Linking Error: ALut.lib

Ah. Right. I have 15a now. Never had to work with source control before, so it's all new to me.

First I got this error:
  • error C2220: warning treated as error - no 'object' file generated c:\users\joseph\documents\bitfightersource\zap\gameconnection.cpp 1176 bitfighter
  • warning C4101: 'gametypeName' : unreferenced local variable c:\users\joseph\documents\bitfightersource\zap\gameconnection.cpp 1176 bitfighter

Easy fix, right? I just deleted the declaration of the variable.

Now it's giving me 300+ linking errors in Debug mode and 40+ linking errors in Release mode. For example

  • Error 283 error LNK2001: unresolved external symbol "public: __thiscall Zap::Color::Color(float)" (??0Color@Zap@@QAE@M@Z) C:\Users\Joseph\Documents\BitfighterSource\zap\teamInfo.obj bitfighter
  • Error 62 error LNK2001: unresolved external symbol "public: class Zap::Point __thiscall Zap::Rect::getExtents(void)" (?getExtents@Rect@Zap@@QAE?AVPoint@2@XZ) C:\Users\Joseph\Documents\BitfighterSource\zap\game.obj bitfighter

I've cleaned the bitfighter build and tried agian. I tried building in both debug and release mode. I have no clue what's going on, I am a C++ newbie, though I have used AS3 a lot and C# a little.

PS. I am using Visual C++ 2010 Express.
<<

Skybax

User avatar

Posts: 1003

Joined: Thu Mar 11, 2010 9:17 am

Location: Washington

Post Sat May 28, 2011 3:28 pm

Re: Linking Error: ALut.lib

I knew that reminded me of my C++ class for a reason…
raptor wrote:Sorry Skybax, I hijacked your signature so I could post lots of info.
Whittling While wrote:Does this mean I finally get quoted in someone's signature?
watusimoto wrote:Who are the devs around here?!?
<<

raptor

Posts: 1022

Joined: Mon Oct 11, 2010 9:03 pm

Post Sat May 28, 2011 3:54 pm

Re: Linking Error: ALut.lib

Those linking errors are usually because a couple files weren't compiled because they are missing from the project. I think sam686 did this release and used the vc++ 2008 project, so it may be that certain files are missing from the vc++2010 project.

I have a hunch that at least these three class files may be missing from the vc++ 2010 project (from the zap/ folder):

  Code:
Color.cpp
Rect.cpp
Point.cpp
<<

Unknown

User avatar

Posts: 183

Joined: Mon Mar 08, 2010 4:48 pm

Post Sun May 29, 2011 8:37 am

Re: Linking Error: ALut.lib

Looking through the errors, all of them have to do with those three classes. However, it seems that the files are included. They are all listed in the menus, none of them with "exclude from project" or anything

However, when I went into the folder "zap\Debug" and "zap\Release", there was no "Rect.obj", "Point.obj", or "Color.obj". I'm guessing all of those are supposed to be there. I tried "add existing files", but there was no change. I tried cleaning the project and compiling again, with no success.
<<

karamazovapy

Posts: 1567

Joined: Tue Feb 23, 2010 7:52 pm

Post Sun May 29, 2011 9:27 am

Re: Linking Error: ALut.lib

Can you try the vc++ 2008 project?
<<

Unknown

User avatar

Posts: 183

Joined: Mon Mar 08, 2010 4:48 pm

Post Sun May 29, 2011 2:24 pm

Re: Linking Error: ALut.lib

Got that one to work after both finding the solution file and adding tnl and libtomcrpt to the solution.

Thanks guys!

Return to Technical Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron