FAQ  •  Register  •  Login

OSX compatibility, 2018 edition

<<

raptor

Posts: 1021

Joined: Mon Oct 11, 2010 9:03 pm

Post Sat Mar 31, 2018 11:13 am

OSX compatibility, 2018 edition

Hi all,

Does anyone run OSX Snow Leopard (10.6) anymore?

Also, does anyone run OSX on a 32-bit machine?

I have made some code changes that requires OSX 10.7 or greater, with 64-bit processor and I hope I do not break anyone. These changes are to make it easier for the game to be maintained on OSX.

Thanks
<<

Quartz

User avatar

Posts: 879

Joined: Thu Jun 17, 2010 12:14 am

Location: Commie California

Post Sat Mar 31, 2018 1:02 pm

Re: OSX compatibility, 2018 edition

10.7 was the last good OS X, before they started making regressive and largely pointless changes. Seems smart.

Mine is 64-bit, sorry.
Exploits of Quartz and bobdaduck - My maps on Pleiades
Current self-serving quote:
raptor wrote:sometimes I think getting Quartz to use plugins is like getting my mom to use a computer
<<

watusimoto

Site Admin

Posts: 1556

Joined: Tue Feb 23, 2010 7:07 pm

Location: Quartz's mom's house

Post Sun Apr 01, 2018 5:16 pm

Re: OSX compatibility, 2018 edition

Sky_lark did in the past, as I recall. I think he was the main reason we stuck with 32-bit for so long.
<<

sky_lark

User avatar

Posts: 1890

Joined: Wed Mar 10, 2010 6:00 pm

Location: North Carolina

Post Tue Apr 03, 2018 5:02 pm

Re: OSX compatibility, 2018 edition

Thanks <3 I still use the same laptop I've had for a few years (macbook pro, mid-2012) but I did finally bite the bullet and upgrade to High Sierra a few weeks ago. I'm pretty sure that means I'm 64-bit!
Follow Bitfighter! FacebookTwitterDiscordSteam
<<

amgine

Posts: 1314

Joined: Thu Apr 19, 2012 2:57 pm

Post Fri Apr 06, 2018 9:35 pm

Re: OSX compatibility, 2018 edition

Does this mean we should no longer support 32 bit bitfighter?
Bitfighter Forever.
<<

raptor

Posts: 1021

Joined: Mon Oct 11, 2010 9:03 pm

Post Fri Apr 06, 2018 10:07 pm

Re: OSX compatibility, 2018 edition

No we easily support 32-bit. It's just that OSX has made it very difficult to compile for it natively anymore. It can still be done, just with significant more effort.

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests

cron